You have no items in your shopping cart.

Kalypso Media

Dungeons 3 - Evil of the caribbean (DLC)

Windows, Mac, Linux | Steam
in stock
4.19Incl. 21% Tax
€4.99-16%
Add to Cart
  • Steam Account Required

    Your game has to be activated, installed and downloaded via Steam. more information »


Product information

Partner Kalypso Media
Activation Steam
Product type DLC
System Linux, Mac, Windows
Language DE, ES, FR, IT, UK
Genre Strategy
Shipping Digital
Availability Instant download delivery
Age rating PEGI Rating 16
Release date

How it works

1
SAFE SHOPPING Numerous payment methods and certified security - game on!
2
Your Game directly by e-mail Get your code or your download-link by e-mail just a few minutes after purchase.
3
play immediately After getting your game, you can activate the full version, download and play immediately.

Product description

NOTE : Requires the base game Dungeons 3 in order to play. Activation key must be used on a valid Steam account, requires internet connection.

About the game

After her numerous adventures, Thalya has earned herself some peace and quiet, and so the Never-Gives-Subordinates-Vacation Evil sends her to the pirate holiday paradise of Turtoga. However, it still has a few teeny tiny tasks for its general, such as rum running, still not paying off gambling debts and dealing with creatures from the depths of the ocean (Cthollho or something like that).

  • 3 Campaign maps with audio
  • 3 new Evil hubs
  • New Wall Tile Set for the Dungeon
  • New Outfit: Thalya the pirate

System Requirements

Windows - Minimum
  • OS: Windows 7 64-bit
  • Processor: Intel Quad Core 2.8 GHz (i7 900 series) or 3.5 GHz AMD (FX 6000 series)
  • RAM: 4 GB RAM
  • Graphics card: AMD/NVIDIA dedicated graphic card, with at least 1024MB of dedicated VRAM and with at least DirectX 11 and Shader Model 5.0 support (AMD Radeon HD 7000 series and NVIDIA GeForce GTX 600 series)
  • DirectX: Version 11
  • HDD: 5 GB available space
Windows - Recommended
  • OS: Windows 10 64-bit
  • Processor: Quad core 3.5 GHz or higher (Intel i5 4000 Series / AMD Ryzen 3 Series)
  • RAM: 8 GB RAM
  • Graphics card: AMD/NVIDIA dedicated graphic card, with at least 3072MB of dedicated VRAM and with at least DirectX 11 and Shader Model 5.0 support (AMD R9 300 Series and NVIDIA GeForce GTX 900 Series or better)
  • DirectX: Version 11
  • HDD: 5 GB available space
Mac - Minimum
  • OS: macOS "Sierra" 10.2
  • Processor: 2.8 GHz Quad Core
  • RAM: 4 GB RAM
  • Graphics card: AMD/NVIDIA dedicated graphic card, with at least 1024MB of dedicated VRAM and with at least DirectX 11 and Shader Model 5.0 support (AMD Radeon HD 7000 series and NVIDIA GeForce GTX 600 series)
  • HDD: 5 GB available space
Mac - Recommended
  • OS: Mac OS X 10.11.x
  • Processor: Quad core 3.5 GHz or higher
  • RAM: 8 GB RAM
  • Graphics card: AMD/NVIDIA dedicated graphic card, with at least 3072MB of dedicated VRAM and with at least DirectX 11 and Shader Model 5.0 support (AMD R9 300 Series and NVIDIA GeForce GTX 900 Series or better)
  • HDD: 5 GB available space
Linux - Minimum
  • OS: Ubuntu 16.04.3 LTS + SteamOS (latest)
  • Processor: Intel Quad Core 2.8 GHz (i7 900 series) or 3.5 GHz AMD (FX 6000 series)
  • RAM: 4 GB RAM
  • Graphics card: AMD/NVIDIA dedicated graphic card, with at least 1024MB of dedicated VRAM and with at least DirectX 11 and Shader Model 5.0 support (AMD Radeon HD 7000 series and NVIDIA GeForce GTX 600 series)
  • HDD: 5 GB available space
  • Additional Notes: Other Linux distributions (Mint, etc.) MIGHT work but we cannot give official support for them
Linux - Recommended
  • OS: Ubuntu 16.04.3 LTS + SteamOS (latest)
  • Processor: Quad core 3.5 GHz or higher (Intel i5 4000 Series / AMD Ryzen 3 Series)
  • RAM: 8 GB RAM
  • Graphics card: AMD/NVIDIA dedicated graphic card, with at least 3072MB of dedicated VRAM and with at least DirectX 11 and Shader Model 5.0 support (AMD R9 300 Series and NVIDIA GeForce GTX 900 Series or better)
  • HDD: 5 GB available space
  • Additional Notes: Other Linux distributions (Mint, etc.) MIGHT work but we cannot give official support for them

System requirements

Windows - Minimum
  • OS: Windows 7 64-bit
  • Processor: Intel Quad Core 2.8 GHz (i7 900 series) or 3.5 GHz AMD (FX 6000 series)
  • RAM: 4 GB RAM
  • Graphics card: AMD/NVIDIA dedicated graphic card, with at least 1024MB of dedicated VRAM and with at least DirectX 11 and Shader Model 5.0 support (AMD Radeon HD 7000 series and NVIDIA GeForce GTX 600 series)
  • DirectX: Version 11
  • HDD: 5 GB available space
Windows - Recommended
  • OS: Windows 10 64-bit
  • Processor: Quad core 3.5 GHz or higher (Intel i5 4000 Series / AMD Ryzen 3 Series)
  • RAM: 8 GB RAM
  • Graphics card: AMD/NVIDIA dedicated graphic card, with at least 3072MB of dedicated VRAM and with at least DirectX 11 and Shader Model 5.0 support (AMD R9 300 Series and NVIDIA GeForce GTX 900 Series or better)
  • DirectX: Version 11
  • HDD: 5 GB available space
Mac - Minimum
  • OS: macOS "Sierra" 10.2
  • Processor: 2.8 GHz Quad Core
  • RAM: 4 GB RAM
  • Graphics card: AMD/NVIDIA dedicated graphic card, with at least 1024MB of dedicated VRAM and with at least DirectX 11 and Shader Model 5.0 support (AMD Radeon HD 7000 series and NVIDIA GeForce GTX 600 series)
  • HDD: 5 GB available space
Mac - Recommended
  • OS: Mac OS X 10.11.x
  • Processor: Quad core 3.5 GHz or higher
  • RAM: 8 GB RAM
  • Graphics card: AMD/NVIDIA dedicated graphic card, with at least 3072MB of dedicated VRAM and with at least DirectX 11 and Shader Model 5.0 support (AMD R9 300 Series and NVIDIA GeForce GTX 900 Series or better)
  • HDD: 5 GB available space
Linux - Minimum
  • OS: Ubuntu 16.04.3 LTS + SteamOS (latest)
  • Processor: Intel Quad Core 2.8 GHz (i7 900 series) or 3.5 GHz AMD (FX 6000 series)
  • RAM: 4 GB RAM
  • Graphics card: AMD/NVIDIA dedicated graphic card, with at least 1024MB of dedicated VRAM and with at least DirectX 11 and Shader Model 5.0 support (AMD Radeon HD 7000 series and NVIDIA GeForce GTX 600 series)
  • HDD: 5 GB available space
  • Additional Notes: Other Linux distributions (Mint, etc.) MIGHT work but we cannot give official support for them
Linux - Recommended
  • OS: Ubuntu 16.04.3 LTS + SteamOS (latest)
  • Processor: Quad core 3.5 GHz or higher (Intel i5 4000 Series / AMD Ryzen 3 Series)
  • RAM: 8 GB RAM
  • Graphics card: AMD/NVIDIA dedicated graphic card, with at least 3072MB of dedicated VRAM and with at least DirectX 11 and Shader Model 5.0 support (AMD R9 300 Series and NVIDIA GeForce GTX 900 Series or better)
  • HDD: 5 GB available space
  • Additional Notes: Other Linux distributions (Mint, etc.) MIGHT work but we cannot give official support for them

Reviews

Write a review

Only registered users can write reviews. Please, log in or register

This might also interest you

Shadowhunters – HD – DUB/LEG Online | Brent Miller | U2 - I'll Go Crazy If I Don't Go Crazy Tonight